欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

Play on Words[HDU1116]

系統 1813 0

Play on Words

Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4094????Accepted Submission(s): 1328

?

Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

?

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
?

?

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
?

?

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
?

?

Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
?

?

Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
?

?

Source
Central Europe 1999
?

?

Recommend
Eddy

Take letters 'a'..'z' as the nodes in graph.A word start with charcateristic c1 and end by characteristic c2 forms an edge in the graph.Then the problem become if there exist an Euler circuit.
So how can we judge whether a graph exists an Euler circuit or not ? First the graph should be a connected graph.We can determine this by breadth-first search.Then we have to check the in-degree and out-degree.Only two or zero if them can be different.If there are two difference,one of the two its in-degree minus its out-degree should be one while the other should be minus one.

?

      #include<stdio.h>

#include<string.h>

#include<queue>

#include<iostream>

using namespace std;

int dr[26],dc[26],N,f[26];

bool e[26],g[26][26];

bool bfs()

{

	int i;

	memset(f,0,sizeof(f));

	queue<int> q;

	while (!q.empty()) q.pop();

	for (i=0;i<26;i++)

		if (e[i])

		{

			f[i]=true;

			q.push(i);

			break;

		}

	while (!q.empty())

	{

		int x=q.front();

		q.pop();

		for (i=0;i<26;i++)

			if (g[x][i])

			{

				if (!f[i])

				{

					f[i]=true;

					q.push(i);

				}

			}

	}

	for (i=0;i<26;i++)

		if ((e[i]) && (!f[i])) return false;

	return true;

}

int main()

{

	int T,i;

	scanf("%d",&T);

	while (T--)

	{

		scanf("%d",&N);

		char s[1024];

		memset(g,0,sizeof(g));

		memset(e,0,sizeof(e));

		memset(dr,0,sizeof(dr));

		memset(dc,0,sizeof(dc));

		for (i=1;i<=N;i++)

		{

			scanf("%s",s);

			int u=s[0]-'a',v=s[strlen(s)-1]-'a';

			g[u][v]=true;

			g[v][u]=true;

			e[u]=true;

			e[v]=true;

			dc[u]++;

			dr[v]++;

		}

		bool flag=bfs();

		int cnt0=0,cnt1=0;

		for (i=0;i<26;i++)

		{

			if (dr[i]-dc[i]>1 || dr[i]-dc[i]<-1) flag=false;

			if (dr[i]-dc[i]==1) cnt0++;

			if (dr[i]-dc[i]==-1) cnt1++;

		}

		if (!((cnt0==0 && cnt1==0)||(cnt0==1 && cnt1==1))) flag=false;

		if (flag) printf("Ordering is possible.\n");

		else printf("The door cannot be opened.\n");

	}

	return 0;

}


    

?

?

?

Play on Words[HDU1116]


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦?。。?/p>

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 精品卡1卡二卡3卡 | 三级a做爰大乳在线观看 | 国产日韩精品一区 | 亚洲欧美一区二区久久香蕉 | 成熟自由日本语热亚洲人 | 久久AV亚洲精品一区无码 | 黑人巨大videosjapan高清 婷婷在线免费观看 | 日韩成人性视频 | 丁香婷婷色综合亚洲小说 | 免费观看视频91 | 天天操一操 | 亚洲一区中文字幕 | 欧美日韩一区二区在线观看视频 | 亚洲国产成人va在线观看网址 | 国产精品国产精品国产专区不卡 | av电影网站在线观看 | 国产成人小视频 | 91看片淫黄大片一级在线观看 | 美女视频一区 | 精品综合久久久久久99 | 免费色网址 | 91精品久久久久久综合五月天 | 麻豆专区一区二区三区四区五区 | 欧美精品在线一区二区三区 | 国产精品欧美一区二区三区不卡 | 黑人群姣中国妞在线观看 | 国产欧美日韩在线观看 | 成人免费视频网站在线观看 | 九九热在线免费观看 | 欧美在线你懂的 | www.av88| 九九热久久免费视频 | av网址在线| 2022国产91精品久久久久久 | 国产99999 | 激情做a全过程片A | 成人性生交大片 | 精品亚洲永久免费精品 | 欧美人与动物xx | 免费观看黄的小视频 | 老妇毛片 |