欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

SZU:B54 Dual Palindromes

系統 1828 0

Judge Info

  • Memory Limit: 32768KB
  • Case Time Limit: 10000MS
  • Time Limit: 10000MS
  • Judger: Number Only Judger

Description

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)

and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10). Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

Input

The first line of input contains?, the number of test cases.

For each test case, there is a single line with space separated integers N and S.

Output

For each test case output N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

Sample Input

    2

3 25

1 25


  

Sample Output

    26

27

28

26
  

?

解題思路:找兩個1~10進制之間的回文數字,當時看成找1個回文數字就可以通過,所以導致好久才AC,看題失誤!

      
         1
      
       #include <stdio.h>


      
         2
      
       #include <
      
        string
      
      .h>


      
         3
      
      
         4
      
      
        char
      
       A[
      
        200
      
      
        ];


      
      
         5
      
      
        int
      
      
         main()


      
      
         6
      
      
        {


      
      
         7
      
      
        int
      
      
         num,r,i,n,j,t,k,ke,mark,len,last,flag;


      
      
         8
      
           scanf(
      
        "
      
      
        %d
      
      
        "
      
      ,&
      
        n);


      
      
         9
      
      
        while
      
      (n--
      
        ){


      
      
        10
      
               scanf(
      
        "
      
      
        %d %d
      
      
        "
      
      ,&last, &
      
        k);


      
      
        11
      
      
        while
      
      (last--
      
        ){


      
      
        12
      
                   ++
      
        k;


      
      
        13
      
      
        14
      
                   flag=
      
        0
      
      
        ;


      
      
        15
      
      
        for
      
      (r=
      
        2
      
      ;r<=
      
        10
      
      ;r++
      
        ){


      
      
        16
      
                       i=
      
        0
      
      
        ;


      
      
        17
      
                       num=
      
        k;


      
      
        18
      
                       mark=
      
        1
      
      
        ;


      
      
        19
      
      
        20
      
      
        while
      
      (num>
      
        0
      
      
        ){


      
      
        21
      
                           t=num%
      
        r;


      
      
        22
      
                           A[i]= t+
      
        '
      
      
        0
      
      
        '
      
      
        ;    


      
      
        23
      
                           ++
      
        i;


      
      
        24
      
                           num/=
      
        r;


      
      
        25
      
      
                        }


      
      
        26
      
                        len = i-
      
        1
      
      
        ;


      
      
        27
      
      
        28
      
      
        for
      
      (i=
      
        0
      
      ,j=len;i<=j;i++,j--
      
        ){


      
      
        29
      
      
        if
      
      (A[i]!=
      
        A[j])


      
      
        30
      
                               mark=
      
        0
      
      
        ;


      
      
        31
      
      
                        }


      
      
        32
      
      
        33
      
      
        if
      
      (mark==
      
        1
      
      
        ){


      
      
        34
      
                           flag++
      
        ;


      
      
        35
      
      
                        }


      
      
        36
      
      
        if
      
      (flag==
      
        2
      
      
        ){


      
      
        37
      
                           printf(
      
        "
      
      
        %d\n
      
      
        "
      
      
        , k);


      
      
        38
      
      
        break
      
      
        ;                    


      
      
        39
      
      
                        }


      
      
        40
      
      
                    }


      
      
        41
      
      
        if
      
      (flag!=
      
        2
      
      
        )


      
      
        42
      
                       ++
      
        last;


      
      
        43
      
      
                }


      
      
        44
      
      
            }


      
      
        45
      
      
        return
      
      
        0
      
      
        ;


      
      
        46
      
       }
    

?

SZU:B54 Dual Palindromes


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 久操中文在线 | 亚洲国产区 | 亚洲精品无码成人A片在线虐 | 欧美日韩一区二区不卡 | 亚洲爽| 美女久久 | 毛片短视频 | 亚洲一区播放 | 欧美日韩亚洲一区二区 | 九九色综合 | 亚洲一区在线免费观看 | 国产精品久久久久久 | 久久99草 | av不卡免费在线 | 人人干免费 | 日韩欧美国产偷亚洲清高 | 亚洲九九 | 99久久中文字幕伊人 | 香港一级毛片在线播放 | 免费福利视频在线观看 | 欧美成人在线免费观看 | 国产色司机在线视频免费观看 | 五月激情六月婷婷 | av资源首页 | 国产一区二区三区国产精品 | 国产视频高清在线观看 | 免费一级欧美片片线观看 | 91在线播放视频 | 九九精品激情在线视频 | 日本在线亚州精品视频在线 | 视频一区二区中文字幕 | 色狠狠xx| 奇米影视小说 | 大伊香蕉精品视频在线天堂 | 亚洲精品不卡久久久久久 | 91中文字幕在线观看 | 欧美成人观看视频在线 | 日韩精品一区二区电影 | 久久综合桃花 | 欧美色性视频 | 国产原创视频在线 |