欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

hdu 3309 Roll The Cube ( bfs )

系統 2217 0

Roll The Cube

Time Limit: 3000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 345????Accepted Submission(s): 127

?

Problem Description
This is a simple game.The goal of the game is to roll two balls to two holes each.
'B' -- ball
'H' -- hole
'.' -- land
'*' -- wall
Remember when a ball rolls into a hole, they(the ball and the hole) disappeared, that is , 'H' + 'B' = '.'.
Now you are controlling two balls at the same time.Up, down , left , right --- once one of these keys is pressed, balls exist roll to that direction, for example , you pressed up , two balls both roll up.
A ball will stay where it is if its next point is a wall, and balls can't be overlap.
Your code should give the minimun times you press the keys to achieve the goal.
?

?

Input
First there's an integer T(T<=100) indicating the case number.
Then T blocks , each block has two integers n , m (n , m <= 22) indicating size of the map.
Then n lines each with m characters.
There'll always be two balls(B) and two holes(H) in a map.
The boundary of the map is always walls(*).
?

?

Output
The minimum times you press to achieve the goal.
Tell me "Sorry , sir , my poor program fails to get an answer." if you can never achieve the goal.
?

?

Sample Input
4 6 3 *** *B* *B* *H* *H* *** 4 4 **** *BB* *HH* **** 4 4 **** *BH* *HB* **** 5 6 ****** *.BB** *.H*H* *..*.* ******
?

?

Sample Output
3 1 2 Sorry , sir , my poor program fails to get an answer.
?

?

Author
MadFroG
?

?

Source


思路:
bfs,用兩個球的位置來判重,其他的直接模擬就ok了。最好將球和洞分開看,還有就是注意一下兩個球不能在同一個位置。

代碼:
      #include <iostream>

#include <cstdio>

#include <cstring>

#include <queue>

#define maxn 25

#define INF 0x3f3f3f3f

using namespace std;



int n,m,ans;

int sx[2],sy[2];

int dx[]= {-1,1,0,0};

int dy[]= {0,0,-1,1};

bool vis[maxn][maxn][maxn][maxn];

char mp[maxn][maxn];

char s[maxn];

struct Node

{

    int x[2],y[2],step;

    int b[2],h[2];   // 球 洞  球是否進洞和洞是否被求填滿分開看

} cur,now;

queue<Node>q;



bool bfs()

{

    int i,j,t,flag;

    memset(vis,0,sizeof(vis));

    while(!q.empty()) q.pop();

    cur.x[0]=sx[0],cur.y[0]=sy[0];

    cur.x[1]=sx[1],cur.y[1]=sy[1];

    cur.h[0]=cur.h[1]=0;

    cur.b[0]=cur.b[1]=0;

    cur.step=0;

    vis[sx[0]][s[0]][sx[1]][sy[1]]=1;

    q.push(cur);

    while(!q.empty())

    {

        now=q.front();

        q.pop();

        for(i=0; i<4; i++)

        {

            cur=now;

            for(j=0; j<2; j++)

            {

                if(cur.b[j]) continue ;

                cur.x[j]+=dx[i];

                cur.y[j]+=dy[i];

                if(mp[cur.x[j]][cur.y[j]]=='*')

                {

                    cur.x[j]-=dx[i];

                    cur.y[j]-=dy[i];

                }

            }

            if(vis[cur.x[0]][cur.y[0]][cur.x[1]][cur.y[1]]||cur.x[0]==cur.x[1]&&cur.y[0]==cur.y[1]&&cur.b[0]+cur.b[1]==0) continue ;

            cur.step++;

            vis[cur.x[0]][cur.y[0]][cur.x[1]][cur.y[1]]=1;

            flag=1;

            for(j=0; j<2; j++)

            {

                t=mp[cur.x[j]][cur.y[j]];

                if(t<2&&!cur.h[t]) cur.b[j]=1,cur.h[t]=1;

                if(!cur.b[j]) flag=0;

            }

            if(flag)

            {

                ans=cur.step;

                return true ;

            }

            q.push(cur);

        }

    }

    return false ;

}

int main()

{

    int i,j,t,cnt1,cnt2;

    scanf("%d",&t);

    while(t--)

    {

        scanf("%d%d",&n,&m);

        cnt1=cnt2=0;

        for(i=1; i<=n; i++)

        {

            scanf("%s",s);

            for(j=1; j<=m; j++)

            {

                mp[i][j]=s[j-1];

                if(mp[i][j]=='H') mp[i][j]=cnt1++;

                else if(mp[i][j]=='B') sx[cnt2]=i,sy[cnt2]=j,cnt2++;

            }

        }

        if(bfs()) printf("%d\n",ans);

        else printf("Sorry , sir , my poor program fails to get an answer.\n");

    }

    return 0;

}


    


?

?

hdu 3309 Roll The Cube ( bfs )


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 久久久久成人精品亚洲国产 | 一区二区在线看 | 中文区永久区 | 一区二区av | 色欧美色| 久久久成| 五月婷婷在线播放 | 综合久久亚洲 | 日韩高清免费在线观看 | 大蕉香蕉久久爱 | 三人弄娇妻高潮3p视频 | 久久精品夜夜夜夜夜久久 | 色噜噜亚洲男人的天堂 | 91高清国产视频 | 成人午夜视频一区二区国语 | 91短视频在线免费观看 | 九九热在线免费观看 | 国产精品久久九九 | 欧美一级永久免费毛片在线 | 一区二区免费在线观看 | 综合色导航 | 国产视频三区 | 国产1区2区3区 | 国产一区二区三区久久久久久久久 | 日韩视频在线观看免费视频 | 欧美国产日韩一区二区三区 | 亚洲综合一二三区 | 午夜资源在线 | 中文字幕日韩欧美 | 在线观看视频色 | 欧美日韩免费观看视频 | hd性videos意大利复古 | 亚洲奇米| 在线视频中文字幕乱人伦 | 日本高清在线精品一区二区三区 | 99在线国产| 人人人人澡 | 亚洲在线资源 | 国产激情久久久久久熟女老人AV | 国产成人视屏 | 午夜理论电影在线观看亚洲 |