欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

Beans-hdu-2845

系統 2453 0


Beans

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1977Accepted Submission(s): 997


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Beans-hdu-2845

Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
      
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
      
242

重點: 橫豎分別求一下不連續的最大子段和;



    #include <iostream>
using namespace std;
int beans[100][100],line[100],row[100];
int main() {
	int m,n;
	while(cin >> m >> n){
		for(int i=0; i<m; i++){
			cin >> beans[i][0] >> beans[i][1];
			row[0] = beans[i][0];
			row[1] = beans[i][1];
			int tmpmax = max(row[0],row[1]);
			row[1] = tmpmax;
			for(int j=2; j<n; j++){
				cin >> beans[i][j];
				row[j] = max(row[j-2] + beans[i][j], row[j-1]);
			}
			line[i] = row[n-1];
		}
		int ans = max(line[0],line[1]);
		line[1] = ans;
		for(int i=2; i<m; i++){
			line[i] = max(line[i-2] + line[i], line[i-1]);
//			if(ans < line[i])
//				ans = line[i];
		}
		cout << line[m-1]  << endl;

	}
	return 0;
}
  




Beans-hdu-2845


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 久久久大片 | 国产电影网 | 欧美久久久无码精品亚洲日韩小说 | 熟女毛片 | 亚洲欧美在线视频免费 | 亚洲第一在线 | 羞羞av在线 | 国产麻豆传媒视频 | 日本在线播放不卡一区二区三区 | 999久久久免费精品国产 | 久久精品一 | 午夜精品久久久久久99热7777 | 男人的午夜天堂 | 911色_911色sss主站色播 | 国产高清在线精品一区二区三区 | 日韩精品网站 | 久久亚洲精品国产一区 | 亚洲欧洲日本天天堂在线观看 | 亚洲av毛片成人精品 | 国产超级乱淫视频播放 | 亚洲免费观看视频 | 美女黄影院 | 久久伊人一区二区三区四区 | 亚洲精品久久久一区二区三区 | 97国产精品视频人人做人人爱 | 青青草在线视频免费观看 | 久爱www成人网免费视频 | 欧美成人精品第一区首页 | 久996视频精品免费观看 | 久草手机在线视频 | 色黄视频免费观看 | 久久天天躁狠狠躁夜夜躁2014 | 日韩在线亚洲 | 亚洲精品播放 | 欧洲一级视频 | 一级免费看片 | 乱子伦xxxxvideos | 天天综合亚洲 | 精品久| 激情视频一区 | 日韩成人在线电影 |