欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

[ACM_HDU_1052]Tian Ji -- The Horse Racing(

系統 2089 0

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9786 Accepted Submission(s): 2718

Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

[ACM_HDU_1052]Tian Ji -- The Horse Racing(貪心算法)

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.


Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.


Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.


Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output
200
0
0


Source
HDU1052


設田忌為a,國王為b,如果兩隊所有未比賽的馬中:

一、如果a的最慢速度大于b的最慢,則直接a的最慢與b的最慢比賽,贏一場;
二、如果a的最慢速度小于b的最慢,則用a的最慢浪費b的最快,輸一場;
三、如果a的最慢速度等于b的最慢,則:
1.如果a的最快速度大于b的最快,則直接a的最快與b的最快進行比賽,贏一場;
2.如果b的最快速度小于b的最快,則用a的最慢浪費b的最快,輸一場;
3.如果a的最快速度等于b的最快,即a與b的最慢與最快分別相等,則:
a.如果a的最慢速度小于b的最快,則用a的最慢浪費b的最快,輸一場;
b.如果a的最慢速度等于b的最快,即a的最慢、a的最快、b的最慢、b的最快相等,說明剩余未比賽的馬速度全部相等,直接結束比賽。

思考為什么不考慮a的最慢大于b的最快的情況?因為a的最快必定大于等于a的最慢,若a的最慢大于b的最快,則a的最快必定也大于b的最快,已經在第二種情況中考慮過了。

    #include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
	int n, i, j;
	int a[1000];
	int b[1000];
	while(scanf("%d", &n) && n){
		for(i = 0; i < n; ++i){
			scanf("%d", &a[i]);
		}
		for(i = 0; i < n; ++i){
			scanf("%d", &b[i]);
		}
		sort(a, a + n);
		sort(b, b + n);
		int begin_a = 0, begin_b = 0, end_a = n - 1, end_b = n - 1, ans = 0;
		for(i = 0; i < n; ++i){
			if(a[begin_a] > b[begin_b]){
				++begin_a;
				++begin_b;
				++ans;
			}else if(a[begin_a] < b[begin_b]){
				++begin_a;
				--end_b;
				--ans;
			}else if(a[end_a] > b[end_b]){
				--end_a;
				--end_b;
				++ans;
			}else if(a[end_a] < b[end_b]){
				++begin_a;
				--end_b;
				--ans;
			}else if(a[begin_a] < b[end_b]){
				++begin_a;
				--end_b;
				--ans;
			}else{
				break;
			}
		}
		printf("%d\n", ans * 200);
	}
	return 0;
}
  

    
      
      
    
  
    

=======================簽 名 檔=======================
原文地址(我的博客): http://www.clanfei.com/2012/05/842.html
歡迎訪問交流,至于我為什么要多弄一個博客,因為我熱愛前端,熱愛網頁,我更希望有一個更加自由、真正屬于我自己的小站,或許并不是那么有名氣,但至少能夠讓我為了它而加倍努力。。
=======================簽 名 檔=======================




[ACM_HDU_1052]Tian Ji -- The Horse Racing(貪心算法)


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 美女久久一区 | 精品久久久久久久久久久 | 成人高清视频免费观看 | 亚洲精品不卡久久久久久 | 欧美一级片毛片 | 久久久久国产精品 | 成人免费播放视频777777 | 久久只有这里有精品 | 黄片毛片免费观看 | 欧美性视频网 | 污污成人一区二区三区四区 | 日韩欧美国内 | 欧美精品38videos性欧美 | 成人精品视频在线观看 | 成人久久久久久久久 | 国产精品一区久久 | www亚洲成人| 991av| 91 在线 | 久久精品99 | 日本在线视频一区二区 | 国产精品视_精品国产免费 亚洲综合在线另类色区奇米 | 鲁一鲁影院 | 色网站综合| 国产欧美日本亚洲精品五区 | 久久久综合九色合综国产 | 国产精品一区二区三区四区 | 亚在线 | 国产成人免费视频网站高清观看视频 | 亚洲第一在线播放 | 午夜欧美精品 | 韩国美女丝袜一区二区 | 91看片在线免费观看 | 天天干夜夜夜 | 日韩五月 | 国产免费叼嘿在线观看 | 天堂成人在线 | a久久久久一级毛片护士免费 | 一区在线播放 | 国产国语一级a毛片高清视频 | 国产中文字幕一区 |