欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

3212 K-Nice(水題1)

系統 1768 0

This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don't, just pretend that you can't see this one.

We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called "nice" when its value equals the sum of its four neighbors. A matrix is called " k -nice" if and only if k of the elements inside the matrix are "nice".

Now given the size of the matrix and the value of k , you are to output any one of the " k -nice" matrix of the given size. It is guaranteed that there is always a solution to every test case.

Input

The first line of the input contains an integer T (1 <= T <= 8500) followed by T test cases. Each case contains three integers n , m , k (2 <= n , m <= 15, 0 <= k <= ( n - 2) * ( m - 2)) indicating the matrix size n * m and it the "nice"-degree k .

Output

For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements in the matrix should not be greater than 10000.

Sample Input

    2

4 5 3

5 5 3


  

?

Sample Output

    2 1 3 1 1

4 8 2 6 1

1 1 9 2 9

2 2 4 4 3

0 1 2 3 0

0 4 5 6 0

0 0 0 0 0

0 0 0 0 0

0 0 0 0 0


    



附帶正確代碼和超時代碼,求解為何會超時呢?

正確代碼:

#include?<cstdio>
using ? namespace ?std;
int ?main(){
???? int ?T,?n,?m,?k,?i,?j;
????scanf( " %d " ,?&T);
???? while (T--){
????????scanf( " %d%d%d " ,?&n,?&m,?&k);?
????????k?=?(n- 2 )*(m- 2 )?-?k;
???????? for (i?=? 1 ;?i?<=?n;?i++)?{
????????????printf( " 0 " );
???????????? for (j= 1 ;j<=m- 2 ;j++)
???????????????? if (k> 0 )printf( " ?%d " ,k--); else ?printf( " ?0 " );
????????????printf( " ?0\n " );
????????}
????}
???? return ? 0 ;
}

    
      
        



超時代碼:
#include <iostream>

using namespace std;

int main(int argc, char *argv[])

{
?
int T, n, m, k, i, j;?

?cin>>T;
?
while(T--)
?
{?????

??? cin>>n>>m>>k;
?
k = (n-2)*(m-2) - k;??

??for(i = 1; i <= n; i++)
?
?{????????
?
?? cout<<"0 ";
??
?for(j=1;j<=m-2;j++)???
???
??? ?? if(k>0)
??
? cout<<k--<<" ";
??
? else?? {cout<<"0 "; }
?
?? cout<<"0"<<endl;???
?????
???}?
}?
??
?return 0;

}
//為什么會不對呢?

3212 K-Nice(水題1)


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 青青草久久爱 | 成人在线视频一区 | 一级毛片在线免费观看 | 日本熟妇无码波多野1223 | 欧美一区二区三区 | 日韩深夜福利视频 | 欧美一级在线免费 | 国产91高清在线 | 污污的网站免费在线观看 | 男女交配视频网站 | 欧美一级特黄aaaaaa在线看首页 | 暴力强行进如hdxxx | 午夜剧场操一操 | 亚洲精品亚洲人成人网 | 亚洲一区二区三区中文字幕 | 91麻豆精品国产91久久久更新时间 | 综合二区 | 成人在线免费观看 | 两性视频网 | 成年视频在线观看 | 国产成人激情 | www久久精品 | 狠狠综合久久久久综 | 黑人性xxxⅹxxbbbbb | 97av视频在线播放 | 欧美区在线| 奇米4色| 欧美成人免费午夜全 | 日本精品久久无码影院 | 欧美va在线视频 | 日韩精品 电影一区 亚洲 | 欧美日韩在线第一页 | 日本无码V视频一区二区 | 欧美成人全部视频 | 日本在线视频一区二区 | 成人小视频在线观看 | 国产一区二区三区久久久久久久久 | 午夜爱爱爱爱爽爽爽网站免费 | 欧美精品成人一区二区三区四区 | 高清激情小视频在线观看 | 国产美女亚洲精品久久久综合 |