欧美三区_成人在线免费观看视频_欧美极品少妇xxxxⅹ免费视频_a级毛片免费播放_鲁一鲁中文字幕久久_亚洲一级特黄

[UVA] 10167 - Birthday Cake

系統 1652 0
? Problem G. Birthday Cake ?

?

Background

Lucy and Lily are twins. Today is their birthday. Mother buys a birthday cake for them.Now we put the cake onto a Descartes coordinate. Its center is at (0,0), and the cake's length of radius is 100.

There are 2N (N is a integer, 1<=N<=50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?

Note: the coordinate of a cherry (x , y) are two integers. You must give the line as form two integers A,B(stands for Ax+By=0), each number in the range [-500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.

Input

The input file contains several scenarios. Each of them consists of 2 parts: The first part consists of a line with a number N, the second part consists of 2N lines, each line has two number, meaning (x,y) .There is only one space between two border numbers. The input file is ended with N=0.

Output

For each scenario, print a line containing two numbers A and B. There should be a space between them. If there are many solutions, you can only print one of them.

Sample Input

?

    2

-20 20

-30 20

-10 -50

10 -5

0
  

Sample Output

    0 1
    

題解:暴力枚舉+線性規劃。A、B都是整數且范圍為[-500,500],1<=N<=50,所以暴力枚舉即可。統計一下直線一側點的數目是否為N。注意有點在直線上的情況是不合法的。

代碼:
      
         1
      
       #include<stdio.h>


      
         2
      
       #include<
      
        string
      
      .h>


      
         3
      
       #include<stdbool.h>


      
         4
      
      
         5
      
      
        int
      
      
         i,j,n,m,sum,


      
      
         6
      
           a[
      
        110
      
      ],b[
      
        110
      
      
        ];


      
      
         7
      
      
         8
      
      
        int
      
      
         9
      
      
        init()


      
      
        10
      
      
        {


      
      
        11
      
      
        int
      
      
         i;


      
      
        12
      
           m=
      
        2
      
      *
      
        n;


      
      
        13
      
      
        for
      
      (i=
      
        1
      
      ;i<=m;i++
      
        )


      
      
        14
      
           scanf(
      
        "
      
      
        %d%d
      
      
        "
      
      ,&a[i],&
      
        b[i]);


      
      
        15
      
      
        16
      
      
        return
      
      
        0
      
      
        ;


      
      
        17
      
      
        }


      
      
        18
      
      
        19
      
      
        int
      
      
        20
      
      
        main()


      
      
        21
      
      
        {


      
      
        22
      
      
        int
      
      
         i,j,k,f;


      
      
        23
      
      
        while
      
      (
      
        true
      
      
        )


      
      
        24
      
      
            {


      
      
        25
      
               scanf(
      
        "
      
      
        %d
      
      
        "
      
      ,&
      
        n);


      
      
        26
      
      
        if
      
      (n==
      
        0
      
      ) 
      
        break
      
      
        ;


      
      
        27
      
      
                init();


      
      
        28
      
               f=
      
        0
      
      
        ;


      
      
        29
      
      
        for
      
      (i=-
      
        500
      
      ;i<=
      
        500
      
      ;i++
      
        )


      
      
        30
      
      
                {


      
      
        31
      
      
        for
      
      (j=-
      
        500
      
      ;j<=
      
        500
      
      ;j++
      
        )


      
      
        32
      
      
                    {


      
      
        33
      
                        sum=
      
        0
      
      
        ;


      
      
        34
      
      
        for
      
      (k=
      
        1
      
      ;k<=m;k++
      
        )


      
      
        35
      
      
                        {


      
      
        36
      
      
        if
      
      ((i*a[k]+j*b[k])<
      
        0
      
      ) sum++
      
        ;


      
      
        37
      
      
        if
      
      ((i*a[k]+j*b[k])==
      
        0
      
      ) 
      
        break
      
      
        ;


      
      
        38
      
      
                        }


      
      
        39
      
      
        if
      
      (sum==
      
        n)


      
      
        40
      
      
                        {


      
      
        41
      
                            f=
      
        1
      
      
        ;


      
      
        42
      
                            printf(
      
        "
      
      
        %d %d\n
      
      
        "
      
      
        ,i,j);


      
      
        43
      
      
        break
      
      
        ;


      
      
        44
      
      
                         }


      
      
        45
      
      
                     }


      
      
        46
      
      
        if
      
      (f==
      
        1
      
      ) 
      
        break
      
      
        ;


      
      
        47
      
      
                 }


      
      
        48
      
      
            }


      
      
        49
      
      
        50
      
      
        return
      
      
        0
      
      
        ;


      
      
        51
      
      
        }


      
      
        52
      
    

?

    
      
        ?
      
    
  

[UVA] 10167 - Birthday Cake


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 天天伊人网 | 日韩伦理免费在线观看 | 天天干狠狠操 | 色99色| 2020天天狠天天透天干天天怕 | 美女被免费网站在线视频九色 | 日韩电影免费在线观看中文字幕 | 大色综合色综合资源站 | 国产91久久精品 | 色狠狠狠色噜噜噜综合网 | 欧美a在线| 欧美xxxxx视频在线 | 日韩精品一区二区三区免费观看 | a视频在线免费观看 | 午夜小视频在线播放 | 久久久久久久亚洲视频 | 久久蜜桃av一区二区天堂 | 欧美激情一区二区亚洲专区 | 亚洲欧美日韩在线线精品 | 激情网址在线观看 | 国产精品九九久久99视频 | 日韩欧美亚洲综合久久99e | 手机看片日韩 | 青青久热 | 春色www视频在线观看 | 久久久久无码国产精品一区 | 欧美精品一区二 | 国产人成午夜免视频网站 | 日韩高清一区二区 | 无码国产精品成人午夜视频 | 91免费看 | 波多野结衣一级 | 激情视频免费在线观看 | 一级aaaaaa片毛片在线播放 | 亚洲日本中文字幕天天更新 | 欧美在线成人影院 | 色伊人网 | 欧美成人精品一区二区男人看 | 天天操天天插 | 韩国久久久久无码国产精品 | 午夜剧场操一操 |